1. Рады видеть Вас на русскоязычном форуме TeamSpeak!

    У нас Вы можете скачать последнюю версию:

    Перед регистрацией рекомендуем ознакомиться

    с Правилами форума.

    Присоединяйтесь! Учите и обучайтесь!

    Скрыть объявление
  2. Новая группа "Новичок" на нашем форуме!

    Новые пользователи будут попадать в группу "Новичок".

    Это сделано для того чтобы "Новички" ознакомились с форумом, так как в большинстве случаев проблема с которой вы хотите обратиться уже обсуждалась.

    Перейти в тему обсуждения
    Быстрый переход в группу Пользователь
  3. VPS/VDS и дедикейт сервера в аренду с DDoS защитой

    • Низкий пинг
    • Действующий SLA
    • Рублевые цены без привязки к курсу валют

    Бесплатный тестовый период VPS-OpenVZ

    Попробовать

MusicBot Искажения звука.

Тема в разделе "Вопросы по TeamSpeak 3", создана пользователем Shmitok, 10 июл 2016.

  1. Shmitok

    Shmitok Пользователь

    Регистрация:
    22.06.15
    Сообщения:
    27
    Симпатии:
    1
    Баллы:
    31
    Sinusbot + jts, Centos7 minimal. VDS: 2 ядра. 3Ггц. xenon x5650, 1Gb RAM 1Gbit up/dw.
    Суть проблему, иногда, не всегда, происходят искажения музыки, т.е. как будто пластика/диск поврежденный, перезапуск бота/эфира/машины не помогает. Наблюдается как на стриме так и на локальных файлах. Нужна ваша консультация в чем может быть дело? Запускаю через screen /.sinusbot
    , думал в этом дело, но пока не пробовал запустить через "xinit /opt/ts3soundboard/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 -- /usr/bin/Xvfb :1 -screen 0 800x600x16 -ac" т.к. centos по дефолту такой команды не знает, пока что не разобрался как установить.
     
  2. kapabac

    kapabacIcon Премиум Пользователь

    Регистрация:
    01.11.14
    Сообщения:
    105
    Симпатии:
    50
    Баллы:
    109
    Рекомендую в моменты когда происходят искажения проверить потерю пакетов у себя и у бота (клик правой кнопкой по юзеру, пункт "Информация о подключеии), лично у меня проблема подобных заиканий именно в этом (у меня овнопровайдер) потеря пакетов в эти моменты достигает 2-3%, чего уже достаточно для подобных искажений звука. Если версия синуса 0.9.9 и выше, запускается он командой ./sinusbot находясь в папке с ботом либо в скрине screen -dmS sinus ./sinusbot...
     
  3. darkangel66

    darkangel66Icon TEAM-VOICE.COM ATHP Премиум Пользователь

    Регистрация:
    12.06.12
    Сообщения:
    417
    Симпатии:
    169
    Баллы:
    335
    так же рекомендую проверить загрузку CPU в момент искажений. По описанию похоже на перегрузку по CPU
     
  4. Shmitok

    Shmitok Пользователь

    Регистрация:
    22.06.15
    Сообщения:
    27
    Симпатии:
    1
    Баллы:
    31
    Потерю пакетов отследить не смог, всегда по нулям. Посмотрел загрузку через putty, там значения вполне сносные, на скрине для пробы запущено две станции, оба стримят. И вроде как, кол-во запущеных ботов не влияет на искажения, но это пока не точно, только запустил.
    Нагрузка через панель ВДС. ЦП максимальная нагрузка в районе 5 процентов. ОП на графиках так же держится в районе 30-50%, на другом графике до 80 поднимается и держится. Может быть еще варианты есть у кого? Сам сервер аптайм до 2 месяцев спокойно, пока сам не положу. Пробовали ддосить сверху с нескольких ВДС, не ложится, т.е. канал в принципе не забит. Вещи вроде установки debian вместо centosa могут помочь или нет? Или откат на 6, на сам хостинг притензий нет никаких, ни у меня ни у знакомых, все на нем сидят.
    sAMfxsubCOc.jpg
    7ct5YD0ozk0.jpg
     
  5. darkangel66

    darkangel66Icon TEAM-VOICE.COM ATHP Премиум Пользователь

    Регистрация:
    12.06.12
    Сообщения:
    417
    Симпатии:
    169
    Баллы:
    335
    Дело в том что изнутри VPS вы видите загрузку виртуального vCPU а не CPU хост машины .
    Какая там реальная загрузка может узнать только администратор хостера. Попробуйте написать о наличии проблем с голосом в поддержку хостера, возможно они , имея данные по загрузке ноды, смогут найти решение проблемы. (например мигрировать ваш сервер на соседнюю ноду)
     
  6. Shmitok

    Shmitok Пользователь

    Регистрация:
    22.06.15
    Сообщения:
    27
    Симпатии:
    1
    Баллы:
    31
    Кажется разобрался с искажениям, оказывается оно было только у меня... Затащил не тест несколько людей в комнаты к ботам, никто никаких искажений не слышит, идет абсолютно ровно. Даже сделал запись с микшера с моего ПК, показал, они сказали что такого конечно не слышат, такое не услышать тяжело.
    Был проблема с трансляцией радио, обрубалось каждые несколько часов. Но пока решил через панель sinusbota. Закрывайте тему, благодарю.
     
  7. kapabac

    kapabacIcon Премиум Пользователь

    Регистрация:
    01.11.14
    Сообщения:
    105
    Симпатии:
    50
    Баллы:
    109
    Если честно, то не совсем понятно в чем у вас все-таки была проблема, решили ли вы ее и если решили, то как? Shok_man754
     
  8. Shmitok

    Shmitok Пользователь

    Регистрация:
    22.06.15
    Сообщения:
    27
    Симпатии:
    1
    Баллы:
    31
    У меня был бот в канале. Я всегда заходил и слушал как он играет, и у меня можно сказать каждые 10-20 секунд происходили искажения, я думал вырубать бота. Но позвал несколько пользователей, они послушали и проблемы не услышали, совсем. Т.е. проблема у меня.
    Хотя вот только что один из пользователей услышал искажения, но там были остановки стрима полностью, возможно проблема не у меня а на радио.
     
    • Пост ни о чём Пост ни о чём x 1
Загрузка...